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Duration: 3 Hours                           SOLUTIONS                                     Year: 2025 

Instructions 

1. This paper consists of sections A, B and C with a total of eleven (11) questions. 

2. Answer all questions in section A and B and two (2) questions from section C. 

3. Section A carries sixteen (16) marks, section B fifty four (54) marks and section C 

thirty (30) marks. 

4. Communication devices and any unauthorised materials are not allowed in the       

      examination room. 

5. Write your Examination Number on every page of your answer booklet(s) 
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SECTION A (16 Marks) 

Answer all questions in this section. 

1. For each of the items (i) to (x), choose the correct answer from the given alternatives 

and write its letter beside the item number. 

(i) Which menu option will you use to display the ruler in Microsoft Word? 

A. Home 

B. Insert 

C. View 

D. Review 

Correct answer: C. View 

The ruler in Microsoft Word is found under the View menu. This menu controls 

elements related to how the document appears on the screen, including rulers, gridlines, 

and zoom options. 

(ii) Which cybercrime did the criminal commit when tapping a communication channel 

to get information secretly? 

A. Fraud 

B. Identity theft 

C. Eavesdropping 

D. Phishing 

Correct answer: C. Eavesdropping 

Eavesdropping refers to secretly listening to or intercepting communication without 

authorization. Tapping communication channels to obtain information fits this 

definition. 
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(iii) What type of computer has a large storage capacity and allows hundreds of 

customers to work on the same data at the same time? 

A. Supercomputer 

B. Mainframe computer 

C. Personal computer 

D. Minicomputer 

Correct answer: B. Mainframe computer 

Mainframe computers are designed to support many users simultaneously. They have 

large storage capacity and are commonly used in banks, universities, and large 

organizations. 

(iv) How can you differentiate a flat file database from a relational database? 

A. Flat file database imports data from other software while relational database does 

not 

B. Flat file database contains a single table but relational database includes many tables 

C. Flat file database contains many tables while relational database includes a single 

table 

D. Flat file database offers stronger reporting than relational database 

Correct answer: B 

A flat file database stores all data in one table, which limits flexibility. A relational 

database uses multiple related tables, making it more efficient and organized for large 

datasets. 

(v) What will be the output after executing the following HTML codes? 

A. Tanzania 

B. Tanzania 
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C. Home 

D. url 

Correct answer: B. Tanzania 

The anchor tag displays the text between the opening and closing tags on the webpage. 

The word “Tanzania” appears as a clickable link. 

(vi) Which type of text alignment would you use to align texts evenly along the left and 

right margins in a Word document? 

A. Left alignment 

B. Center alignment 

C. Right alignment 

D. Justified alignment 

Correct answer: D. Justified alignment 

Justified alignment ensures that text is evenly aligned on both the left and right 

margins, giving documents a clean and professional appearance. 

(vii) Which one are the correct procedures for adding a chart in one of the slides in 

PowerPoint? 

A. Insert > Chart > Picture 

B. Picture > Chart > Insert 

C. Insert > Picture > Chart 

D. Picture > Insert > Chart 

Correct answer: C. Insert > Picture > Chart 

Charts in PowerPoint are added through the Insert menu. This allows users to select and 

insert different types of charts into slides. 
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(viii) Which type of chart will be most appropriate for comparing performance of sales 

of two items? 

A. Pie chart 

B. Column chart 

C. Bubble chart 

D. Surface chart 

Correct answer: B. Column chart 

Column charts are effective for comparing quantities between different items because 

the height of the columns makes differences easy to see. 

(ix) How would you protect the computer from malware attacks? 

A. By opening email attachments from unknown sources 

B. By visiting any websites in the World Wide Web 

C. By switching off the computer regularly 

D. By scanning removable devices before opening them 

Correct answer: D 

Scanning removable devices such as flash disks helps detect malware before it spreads 

into the computer system. 

(x) Which type of multimedia is used in computer and smartphone games? 

A. Linear multimedia 

B. Non linear multimedia 

C. Analog multimedia 

D. Visual multimedia 
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Correct answer: B. Non linear multimedia 

Games allow users to interact and make choices that affect outcomes. This interaction 

makes them non linear multimedia. 

2. Match the functions of field properties in List A with their corresponding names of the 

field properties from Microsoft Access in List B. 

List A 

(i) It allows the user to set the type of numbers to be entered in a field. 

(ii) It determines if an entry must be made in the field before proceeding to the next 

field or record. 

(iii) It restricts the values to be entered in a field. 

(iv) It formats automatically the field entry into a specific pattern. 

(v) It allows a message to be displayed once the validation rule is violated. 

(vi) It describes the label for the field to be used in a table or form view. 

List B 

A. Validation Rule 

B. Indexed 

C. Default Value 

D. Caption 

E. Validation Text 

F. Field Size 

G. Input Mask 

H. Required 

Answers. 

(i) F (ii) H (iii) A (iv)G (v)E (vi) D 
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SECTION B (54 Marks) 

Answer all questions in this section. 

3. (a) Why is it advised to close windows and doors in a computer laboratory? Give four 

reasons. 

One reason is to prevent dust from entering the laboratory. Dust can accumulate inside 

computer components and cause overheating or damage. 

Another reason is to protect computers from moisture. Rainwater and humidity can 

cause short circuits and damage electronic parts. 

Closing windows and doors also improves security. It reduces the risk of theft or 

unauthorized access to computer equipment. 

It also helps maintain a controlled temperature. Computers perform better in stable 

temperature conditions. 

(b) What are the two effects of opening windows and doors on computers in a 

laboratory? 

Opening windows allows dust to enter the laboratory, which can damage internal 

components of computers. 

It may also allow moisture to enter, leading to rusting, electrical faults, or system 

failure. 
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4. (a) Why is it prohibited to use liquid fire extinguishers in the computer laboratory? 

Liquid fire extinguishers conduct electricity and can damage computer equipment. 

They also increase the risk of electric shock to users. 

(b) Explain two health problems a person may suffer when using ICT devices for a long 

time. 

One health problem is eye strain. Continuous exposure to screens causes tired eyes, 

headaches, and blurred vision due to excessive screen brightness. 

Another problem is back pain. Sitting for long hours with poor posture puts pressure on 

the spine and muscles. 

(c) Explain two protective ways for each problem explained in part (b). 

To prevent eye strain, users should take regular breaks and adjust screen brightness to a 

comfortable level. 

To reduce back pain, users should use ergonomic chairs and maintain proper sitting 

posture. 

5. (a) Why network administrators in organizations prefer to install Linux operating 

system in their server computers? 

One reason is stability. Linux servers rarely crash, making them reliable for continuous 

operation. 

Another reason is security. Linux is less vulnerable to viruses and malware compared to 

other operating systems. 

Administrators also prefer Linux because it supports multiple users efficiently. 
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(b) What two possible challenges the organization may face when using Linux 

operating system? 

One challenge is limited availability of some commercial software designed mainly for 

other operating systems. 

Another challenge is the need for skilled personnel to manage and maintain Linux 

systems. 

(c) Explain two functions of the Linux operating system used in organization servers. 

Linux manages hardware resources efficiently, ensuring optimal use of memory and 

processing power. 

It also controls user access and security, protecting organizational data. 

6. Form Six students plan to capture a video in their graduation ceremony but lack 

knowledge of video processing. 

(a) Explain five procedures you would use to accomplish the task. 

The first procedure is importing video files into video editing software. 

The second procedure is trimming unwanted sections to remove errors. 

The third procedure is arranging video clips in the correct sequence. 

The fourth procedure is adding transitions, text, and effects to enhance quality. 

The final procedure is exporting the edited video to a flash disk. 

(b) Explain two types of compression method you may use. 

Lossy compression reduces file size by removing some data, slightly affecting quality. 

Lossless compression reduces file size without losing any data. 
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7. You have been assigned to prepare the students’ magazine and submit it through 

email. 

(a) Why did the teacher opt for this way of communication? Give three reasons. 

Email is fast and allows instant delivery of information. 

It is cost effective because it does not require printing or physical transport. 

It allows sending the magazine to many recipients at the same time. 

(b) Explain the function of each field appeared during composing an email. 

The To field contains the main recipient of the email. 

The CC field sends a copy to additional recipients who are allowed to see others. 

The BCC field sends copies without revealing recipients’ addresses. 

8. The Ministry of Health uses television and radio broadcasting to disseminate 

information about pandemic diseases. 

(a) Which type of information dissemination method is used by the Ministry of Health? 

The method used is mass media communication. 

(b) Why does the Ministry use such means of disseminating information? Give four 

reasons. 

Mass media reaches a large population at the same time. 

Information is delivered quickly during emergencies. 

It reaches both literate and illiterate people. 

It covers wide geographical areas. 
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(c) What two challenges would the Ministry face by using such method? 

One challenge is high operational costs. 

Another challenge is limited feedback from the audience. 

SECTION C 

Answer two (2) questions from this section. 

9. Why do most newspaper developers prefer to use desktop publishing programs than 

other programs? Explain by giving five points. 

Their ability to produce professional layouts. Desktop publishing software such as Adobe 

InDesign and Microsoft Publisher allows precise control over text, images, columns, 

margins, and spacing, which is essential for producing attractive and readable 

newspapers. 

Flexibility in text and image editing. Desktop publishing programs allow developers to 

easily edit text, resize images, adjust fonts, and apply styles without affecting the overall 

layout, making corrections and updates faster and more efficient. 

Desktop publishing programs also support high quality printing. They are designed to 

work with printing standards such as color separation and resolution control, ensuring 

that newspapers are printed clearly and professionally. 

Time efficiency. These programs provide ready made templates and tools that speed up 

the design process, allowing newspapers to be produced within tight deadlines. 

Lastly, desktop publishing programs support integration of graphics. Developers can 

easily import photographs, charts, and illustrations, enhancing the visual appeal and 

communication effectiveness of newspapers. 
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10. Recently, most organizations opt to use computer technology instead of human beings 

in their various operations. Using five points, explain the reasons for their choices. 

One major reason organizations use computer technology is  

Speed. Computers can process large amounts of data much faster than humans, enabling 

organizations to complete tasks quickly and meet operational deadlines. 

Accuracy. Computers reduce errors in calculations, data processing, and record keeping, 

leading to more reliable results compared to manual work. 

Cost reduction is also a reason for adopting computer technology. Although initial 

investment may be high, computers reduce long term costs by minimizing labor expenses 

and increasing productivity. 

Computers also allow efficient data storage and retrieval. Large volumes of information 

can be stored digitally and accessed easily whenever needed, improving decision making 

and organizational efficiency. 

Finally, computer technology enables automation. Routine and repetitive tasks can be 

automated, allowing human workers to focus on more complex and creative activities. 

11. Explain five advantages of using computers and other devices which are connected to 

the network in an organization. 

One advantage of using networked computers is  

Improved communication. Employees can share information quickly through emails, 

messaging systems, and shared platforms, enhancing coordination within the 

organization. 

Resource sharing. Devices connected to a network can share printers, files, and internet 

connections, reducing costs and improving efficiency. 
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Networked computers also improve data management. Centralized databases allow 

secure storage, easy updating, and controlled access to organizational information. 

Enhanced collaboration. Employees can work on shared documents and projects 

simultaneously, even from different locations, increasing teamwork and productivity. 

Support better security and backup. Organizations can implement centralized security 

controls and regular data backups, protecting information from loss or unauthorized 

access. 
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