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Instructions
1. This paper consists of three questions

2. Answer two questions.
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1. Kenyana is a newly established secondary school with a vision of using ICT in its operations. Mr. Mchulli,
the Head of the school employed you to develop the school’s website, which includes the calendar in the
home page as shown in the following screenshot. Use HTML codes to accomplish this task.

Hint:
- Use a table in designing a webpage.
- You can use any picture from your computer gallery.

Page descriptions:

- The heading “School Calendar” should be level 1 with red text color and gray background color.

- The size of the texts “School Picture & Events,” “July, 2020,” and “Staffs & Students Pictures” should be
h3 with green background color.

- Font style for “Form IV students” should be Lucida Handwriting.

- The height and width of each picture should be 100 and 210 respectively.

- Table border should be 1 and rowspan should be 2.

- The size of months name and dates should be h4.

Solution:
<IDOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>School Calendar</title>
<style>
body {
font-family: Arial, sans-serif;
}
hl{
color: red:;
background-color: gray;
text-align: center;

}
h3 {
color: green;
background-color: lightgreen;
}
Jucida {
font-family: "Lucida Handwriting™, cursive;
}
table {

width: 100%;
border-collapse: collapse;
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border: 1px solid black;
}
table, th, td {
border: 1px solid black;
}
th, td {
text-align: center;
padding: 10px;
}
img {
height: 100px;
width: 210px;
}
h4-style {
font-size: 18px;
}
</style>
</head>
<body>
<h1>School Calendar</h1>
<table>
<tr>
<th colspan="2" rowspan="2"><h3>School Picture & Events</h3></th>
<th colspan="2"><h3>July, 2020</h3></th>
<th colspan="2"><h3>Staffs & Students Prefects</h3></th>
</tr>
<tr></tr>
<tr>
<td rowspan="6"><img src="school_picture.jpg" alt="School Picture"></td>
<td rowspan="6">
<ul>
<li>Jan 09 - Opening Day</li>
<li>Jan 12 - School Baraza</li>
<li>July 31 - School Day</li>
<li>August 24 - School Bonanza</li>
<li>Dec 20 - Closing Day</li>
</ul>
</td>
<td colspan="2" class="h4-style">Su Mo Tu We Th Fr Sa</td>
<td rowspan="6">
<img src="headmaster.jpg" alt="Headmaster">
<p class="lucida">Form IV Students</p>
</td>
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</tr>
<tr>
<td colspan="2" class="h4-style">12 3 4 5 6 7</td>
<ftr>
<tr>
<td colspan="2" class="h4-style">8 9 10 11 12 13 14</td>
<[tr>
<tr>
<td colspan="2" class="h4-style">15 16 17 18 19 20 21</td>
<[tr>
<tr>
<td colspan="2" class="h4-style">22 23 24 25 26 27 28</td>
<[tr>
<tr>
<td colspan="2" class="h4-style">29 30 31</td>
<ftr>
</table>
<p>Current Date: Thursday, 12<sup>th</sup> of July 2020</p>
</body>
</html>

Instructions:

1. Save the code in a file with the ".html" extension, for example, “school_calendar.html".
2. Replace “school_picture.jpg™ and "headmaster.jpg” with the actual paths to the images on your computer.
3. Open the file in a web browser to view the webpage.

2. In his wedding, Ally Kaja got a trouble to design his wedding card and time table. Suppose he asked you
to solve the problem by creating an invitation card and the time table for his wedding:

(a) Use Microsoft Publisher to design the following invitation card. Save your work as Invitation Card.

Page descriptions:

- The background colour should be Accent 2, lighter 60%.

- The border colour and clip arts should be purple.

- The style and colour of the text Invitation card should be WordArt and purple respectively.

- The font style and colour of the text Sandra Mwaka and Ally Kaja should be Kristen ITC and green
respectively.

- Other text should be black coloured with font style Baskerville Old Face and size should be 10.

SOLUTION:
To create the wedding invitation card for Ally Kaja in Microsoft Publisher, follow these detailed steps:

1. Launch Microsoft Publisher
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- Open Microsoft Publisher on your computer and select "Blank Page Sizes" or a template closest to the
card dimensions.
- Set the page size to match the required invitation card.

2. Set the Background Color
- Go to the "Page Design" tab and choose "Background."
- Select the color Accent 2 and set the lighter 60% variation for the entire page.

3. Insert a Border
- Go to the "Insert" tab and select "Shapes."
- Choose a rectangle shape and draw it around the entire page to create the border.
- Set the border's line color to purple by selecting "Shape Outline" and choosing the purple color.

4. Add Clip Art

- From the "Insert" tab, click "Pictures" or "Online Pictures" and search for clip art that matches the style
shown in the example (e.g., gift box, flower).

- Insert the clip arts into the card and position them as required. Set their color to purple using the "Picture
Format™ tab.

5. Create the Title “Invitation Card”
- Go to the "Insert" tab and select "WordArt."
- Choose a WordArt style and type Invitation Card.
- Set the font color to purple, then resize and position it at the top of the card.

6. Add Names “Sandra Mwaka” and “Ally Kaja”
- Insert a text box from the "Insert" tab and type Sandra Mwaka.
- Use the font Kristen ITC and set the font color to green.
- Repeat for Ally Kaja and ensure both names are aligned properly and formatted in the same style.

7. Add the Invitation Text
- Insert another text box for the body of the invitation message.
- Type the message:
You are cordially invited to celebrate
the wedding of our beloved
- Set the font style to Baskerville Old Face, font size to 10, and font color to black.

8. Add Event Details
- Below the names, add another text box for the event details:
On Sunday Afternoon
August 20, 2023, at 4:00 PM
Mlimani Avenue
- Use the same Baskerville Old Face font style, size 10, and black font color.
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9. Add Decorative Elements
- Use additional shapes and lines to create visual separation between sections, if needed.
- Adjust all elements for proper alignment and spacing.

10. Group All Elements

- Select all elements (text boxes, shapes, and images) by holding down the "Ctrl" key and clicking each
item.

- Right-click and select "Group" to ensure the entire design remains intact during adjustments.

11. Save the Design
- Save the file as Invitation Card in your desired folder.

12. Print the Invitation

- Preview the invitation using the "File" > "Print Preview" option to ensure everything appears as
intended.

- Print the card using a suitable printer and high-quality paper.

(b) To create the wedding time table as shown in the image using Microsoft Word, follow these detailed
steps:

1. Open Microsoft Word
- Launch Microsoft Word on your computer.
- Start with a blank document.

2. Set the Title "WEDDING DAY TIME LINE"
- Type "WEDDING DAY TIME LINE" at the top of the document.
- Set the font to Castellar, size 28, and center-align the text.

3. Add the Subheading "of our beloved"
- Type "of our beloved" below the title.
- Set the font style to Lucida Calligraphy, size 20, and center-align the text.

4. Add Names "Sandra Mwaka & Baunsa Kaja"
- Type "Sandra Mwaka & Baunsa Kaja" under the subheading.
- Set the font style to Brush Script MT, size 24, and center-align the text.

5. Insert the Table for the Time Line
- Go to the "Insert" tab and click "Table."
- Create a table with 3 columns and 8 rows.

6. Format the Table Header
- Merge the first-row cells to add the date. Type "25/08/2020" and rotate the text vertically.
- In the second row, type "TIME" in the first cell and "EVENT" in the second and third merged cells.
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- Set the font style for the header row to Times New Roman, size 18.

7. Add Time Line Details
- Fill in the table with the provided data:

TIME EVENT
04:00 Bridal Preparation
Dressing
Make up.
05:00 Wedding Convoy Arrives
Parents arrive at the ceremony.
05:30 Photos with the Parents & Arrival of Guests.
06:15 Photos with Friends.
07:30 Bride & Groom Portraits.
10:00 Dancing.
12:00 End of the Ceremony.
- Set the font style for the TIME and EVENT columns to BatangChe, size 16.

8. Highlight Specific Words
- Change the background color of words like "CHAMPAGNE," "CUTTING CAKE," and "DINNER" to
Tan (Darker 50%).

9. Add Clip Art
- Go to the "Insert" tab, select "Pictures" or "Online Pictures," and choose a decorative clip art.
- Place the clip art at the top of the timetable for decoration.

10. Save the File
- Save the document with the name "Wedding Time Table."

11. Print the Document
- Preview the document to ensure proper alignment and formatting.
- Use "File" > "Print" to print the document.

3. Air Tanzania Company computerized its operations in order to improve online booking for their
customers. All customer bookings are held in a database called ATC BOOKING. The database contains
the following tables named "Passenger" and "Flight." Study the tables carefully and then answer the
questions that follow:

(a) Use the appropriate software to create the database and tables named “Passenger” and “Flight.” Assign
the appropriate data type for each field.

(b) Set the PassengerID and FlightID fields as primary keys.

(c) Create two forms named “Passengerform” and “Flightform” with the current date inserted in the header.
Use the forms created to enter the data for each table.
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(d) Validate the price field in the Flight table so that the field should accept the price which is greater than
100,000. Otherwise, a field should give an alert message “The entered price is too low!”

(e) Create a relationship between two tables.

(f) Create a query that displays all records in the Passenger table where the address has not been entered.
Save the query as No Address.

(9) Create a query that displays Flight Name and Price then add a calculated field called VAT which will
display 18% of the Price. Save the Query as VAT Query.

(h) Print your document.

Solution:

1. Create the Database and Tables
- Open Microsoft Access (or any database management software).
- Create a new database and name it "ATC BOOKING."
- Create the "Passenger" table with the following fields and data types:
- PassengerID (Primary Key) - Text
- Passenger Name - Text
- Address - Text
- Booking Date - Date/Time
- Location - Text
- Create the "Flight" table with the following fields and data types:
- FlightID (Primary Key) - Text
- PassengerID (Foreign Key) - Text
- Flight Name - Text
- Destination - Text
- Price - Number (Currency).

2. Set the Primary Keys
- For the "Passenger" table, set PassengerID as the primary key.
- For the "Flight" table, set FlightID as the primary key.

3. Create Forms
- Use the Form Wizard to create forms for each table.
- Name the forms "Passengerform™ and "Flightform."”
- Add the current date in the header of each form by inserting a text box with the function "=Now()".

4. Validate the Price Field
- In the Flight table, set a validation rule for the Price field: *>100000".
- Add a validation text: "The entered price is too low!"

5. Create a Relationship
- Go to the Relationships tool in the Database Tools tab.
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- Create a one-to-many relationship between PassengerID in the "Passenger” table and PassengerID in
the "Flight" table.

6. Create the No Address Query
- Open the Query Design tool and select the "Passenger" table.
- Add a condition in the Address field: “Is Null’.
- Save the query as "No Address."

7. Create the VAT Query
- Open the Query Design tool and select the "Flight" table.
- Include Flight Name and Price fields in the query.
- Add a calculated field for VAT using the formula: "VAT: [Price]*0.18".
- Save the query as "VAT Query."

8. Print the Document
- Print the tables, forms, and queries by going to "File" > "Print."
- Preview the document to ensure proper formatting.
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